summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:53 +0200
commit7c462e7c2dc0a27397d59e9657edde381b3848c0 (patch)
treee1d18277f5bdee15e4fc5a450f8f3ce379bcb178
parent6427c67aa5c88f0b85fd1c528446d0f27da5a6a2 (diff)
downloadguix-7c462e7c2dc0a27397d59e9657edde381b3848c0.tar.gz
gnu: Add texlive-scontents.
* gnu/packages/tex.scm (texlive-scontents): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 63d6e42ea4..9b13710b9e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94703,6 +94703,29 @@ typesetting; the various styles define the header, footer and title formatting.
 Many features are freely configurable.")
     (license license:lppl1.3+)))
 
+(define-public texlive-scontents
+  (package
+    (name "texlive-scontents")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/scontents/"
+                   "source/latex/scontents/"
+                   "tex/context/third/scontents/"
+                   "tex/generic/scontents/"
+                   "tex/latex/scontents/")
+             (base32
+              "0817f3xjaxli7rjqpr1gl13mx2iba3c0p95y9818kwccj47v71py")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/scontents")
+    (synopsis "Stores LaTeX contents in memory or files")
+    (description
+     "This package stores valid LaTeX code in memory (sequences).  The stored
+content (including verbatim) can be used as many times as desired in the
+document, additionally can be written to external files if desired.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar