summary refs log tree commit diff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-20 14:10:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-20 22:02:49 +0000
commit7c540ed1065bf998ed41b515042fa1b3f30f80fe (patch)
treea2a5b0cbdd8f481bef564422d8288b89e9814188
parentc79ffe25e98607d6803f960d5187e4098e1dc7c2 (diff)
downloadguix-7c540ed1065bf998ed41b515042fa1b3f30f80fe.tar.gz
gnu: python-pandas-stubs: Update to 1.5.3.230321.
* gnu/packages/python-science.scm (python-pandas-stubs): Update to
1.5.3.230321.
[arguments]<#:test-flags>: Ignore tests that require a version of
python-pyarrow with ORC integration.
[native-inputs]: Add python-odfpy.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-science.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3c131fe730..4eb0195889 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -580,8 +580,8 @@ doing practical, real world data analysis in Python.")
     (name "python-pandas-stubs")
     ;; The versioning follows that of Pandas and uses the date of the
     ;; python-pandas-stubs release. This is the latest version of
-    ;; python-pandas-stubs for python-pandas 1.4.4.
-    (version "1.4.4.220919")
+    ;; python-pandas-stubs for python-pandas 1.5.3.
+    (version "1.5.3.230321")
     (source
      (origin
        ;; No tests in the PyPI tarball.
@@ -591,10 +591,21 @@ doing practical, real world data analysis in Python.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "14fhj1y71akwl41ws7cpazsbq5b8wf4rwaydqq2h39q7gylpcp99"))))
+        (base32 "1blwlq5053pxnmx721zdd6v8njiybz4azribx2ygq33jcpmknda6"))))
     (build-system pyproject-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
+     (list
+      #:test-flags #~(list "-k"
+                           (string-append
+                            ;; The python-pyarrow package in Guix is not built
+                            ;; with ORC integration, causing these tests to
+                            ;; fail.
+                            "not test_orc"
+                            " and not test_orc_path"
+                            " and not test_orc_buffer"
+                            " and not test_orc_columns"
+                            " and not test_orc_bytes"))
+      #:phases '(modify-phases %standard-phases
                   (add-before 'check 'prepare-x
                     (lambda _
                       (system "Xvfb &")
@@ -607,6 +618,7 @@ doing practical, real world data analysis in Python.")
     ;; tests will be skipped for now.
     (native-inputs (list python-lxml
                          python-matplotlib
+                         python-odfpy
                          python-pandas
                          python-poetry-core
                          python-pyarrow