summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-05 21:45:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 17:28:39 +0100
commit7c5f064277f5841a3c8d50e621a243d000055d20 (patch)
tree8f7675a5eaf4c21b79f16d3842efb74d04520a80
parent8ce52a25bcdf4d547c589e95371697c6f440888f (diff)
downloadguix-7c5f064277f5841a3c8d50e621a243d000055d20.tar.gz
gnu: Add bcachefs-tools-static.
* gnu/packages/file-systems.scm (bcachefs-tools/static): New public
variable.
-rw-r--r--gnu/packages/file-systems.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc147bf3c6..8c382a0aec 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -386,6 +386,24 @@ caching system, and lets you assign different roles to each device based on its
 performance and other characteristics.")
       (license license:gpl2+))))
 
+(define-public bcachefs-tools/static
+   (package
+     (inherit bcachefs-tools)
+     (name "bcachefs-tools-static")
+     (arguments
+      (substitute-keyword-arguments (package-arguments bcachefs-tools)
+        ((#:make-flags make-flags)
+         `(append ,make-flags
+                  (list "LDFLAGS=-static")))))
+     (inputs
+      `(("eudev:static" ,eudev "static")
+        ("libscrypt:static" ,libscrypt "static")
+        ("lz4:static" ,lz4 "static")
+        ("util-linux:static" ,util-linux "static") ; lib{blkid,uuid}
+        ("zlib" ,zlib "static")
+        ("zstd:static" ,zstd "static")
+        ,@(package-inputs bcachefs-tools)))))
+
 (define-public exfatprogs
   (package
     (name "exfatprogs")