summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:12:57 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:35 +0100
commit7c8ee30ca691c4fdf57f0868fe56e2eaefe878f8 (patch)
treeb9ea893328567f61ca252abc94afce0324f015fb
parentab51be3aba72f857363a2fca3358ef74a1e87d1f (diff)
downloadguix-7c8ee30ca691c4fdf57f0868fe56e2eaefe878f8.tar.gz
gnu: Remove ocaml4.07-bin-prot.
* gnu/packages/ocaml.scm (ocaml4.07-bin-prot): Remove variable.
(ocaml-bin-prot)[properties]: Remove variant.

Change-Id: I8d16ef26b58cc179bcc9d93d2e3e18116c474d25
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 1 insertions, 26 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c31176720b..5010377fc8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6735,8 +6735,7 @@ string conversion.")
             ocaml-ppx-optcomp
             ocaml-ppx-sexp-conv
             ocaml-ppx-variants-conv))
-    (properties `((upstream-name . "bin_prot")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-bin-prot))))
+    (properties `((upstream-name . "bin_prot")))
     (home-page "https://github.com/janestreet/bin_prot")
     (synopsis "Binary protocol generator")
     (description "This library contains functionality for reading and writing
@@ -6747,30 +6746,6 @@ protocol is also heavily optimized for size, making it ideal for long-term
 storage of large amounts of data.")
     (license license:expat)))
 
-(define-public ocaml4.07-bin-prot
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-bin-prot)
-      (version "0.11.0")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
-                                    (version-major+minor version)
-                                    "/files/bin_prot-v" version ".tar.gz"))
-                (sha256
-                 (base32
-                  "1rsd91gx36prj4whi76nsiz1bzpgal9nzyw3pxdz1alv4ilk2il6"))))
-      (propagated-inputs (list ocaml-base
-                               ocaml-ppx-compare
-                               ocaml-ppx-custom-printf
-                               ocaml-ppx-fields-conv
-                               ocaml-ppx-variants-conv
-                               ocaml-migrate-parsetree))
-      (properties '())
-      (license (list
-                 license:asl2.0
-                 license:bsd-3)))))
-
 (define-public ocaml-protocol-version-header
   (package
     (name "ocaml-protocol-version-header")