summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:08:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:08:17 +0200
commit7ca0a0f0e73dbda375d6081604c61a8cb5b1919e (patch)
treea9d9d45ae8005920890bbc2eece3404acf2162e0
parentfd5372e40f9309ec6052b6f7f96f140e63de4efb (diff)
downloadguix-7ca0a0f0e73dbda375d6081604c61a8cb5b1919e.tar.gz
gnu: Add r-biocthis.
* gnu/packages/bioconductor.scm (r-biocthis): New variable.
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 18571d55a1..c78e025ddc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -14014,6 +14014,35 @@ Functions are also provided to enable smooth interoperability of multiple
 Python environments in a single R session.")
     (license license:gpl3)))
 
+(define-public r-biocthis
+  (package
+    (name "r-biocthis")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "biocthis" version))
+       (sha256
+        (base32
+         "08awghsg7q22csb0j9dr8dpb1vkn9gcs9qnhhljxifkw2ahbqia4"))))
+    (properties `((upstream-name . "biocthis")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocmanager" ,r-biocmanager)
+       ("r-fs" ,r-fs)
+       ("r-glue" ,r-glue)
+       ("r-rlang" ,r-rlang)
+       ("r-styler" ,r-styler)
+       ("r-usethis" ,r-usethis)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/lcolladotor/biocthis")
+    (synopsis "Automate package and project setup for Bioconductor packages")
+    (description
+     "This package expands the @code{usethis} package with the goal of helping
+automate the process of creating R packages for Bioconductor or making them
+Bioconductor-friendly.")
+    (license license:artistic2.0)))
+
 (define-public r-tximeta
   (package
     (name "r-tximeta")