summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-18 11:43:45 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-18 23:02:29 +0200
commit7cf080aa71872523dc3dbe856967e4fa5a76030b (patch)
treead6840ad54bc3ff299e55055dc6a00bd8e13bb13
parentb0ec23afb72eecaa2a59fddf5d528255d05d4b3c (diff)
downloadguix-7cf080aa71872523dc3dbe856967e4fa5a76030b.tar.gz
gnu: awscli: Update to 1.22.90.
* gnu/packages/python-web.scm (awscli): Update to 1.22.90.
[arguments] Use search-input-file to find groff.
[inputs]: Replace python-botocore-for-awscli with python-botocore.
Add groff.
[native-inputs]: Remove groff.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 28c934e896..5fcfd27914 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2870,14 +2870,14 @@ supports url redirection and retries, and also gzip and deflate decoding.")
   (package
     ;; Note: updating awscli typically requires updating botocore as well.
     (name "awscli")
-    (version "1.21.11")
+    (version "1.22.90")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri name version))
        (sha256
         (base32
-         "0fkivwbx4nind5b7l4jhqm5bb9drgqsclcslrg4aggf9rcs4g4s0"))))
+         "0ky4ax4xh7s8w1l0hwc7w9ii8afvh9nib3kz09qhiqdinxzrlv54"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: The 'pypi' release does not contain tests.
@@ -2891,21 +2891,22 @@ supports url redirection and retries, and also gzip and deflate decoding.")
                             "setup.py")
                (("<5.5") "<=6"))))
          (add-after 'unpack 'fix-reference-to-groff
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "awscli/help.py"
                (("if not self._exists_on_path\\('groff'\\):") "")
                (("raise ExecutableNotFoundError\\('groff'\\)") "")
                (("cmdline = \\['groff'")
-                (string-append "cmdline = ['" (which "groff") "'"))))))))
+                (string-append "cmdline = ['"
+                               (search-input-file inputs "bin/groff")
+                               "'"))))))))
     (inputs
-     (list python-colorama-for-awscli
-           python-botocore-for-awscli
+     (list groff
+           python-colorama-for-awscli
+           python-botocore
            python-s3transfer
            python-docutils-0.15
            python-pyyaml
            python-rsa))
-    (native-inputs
-     (list groff))
     (home-page "https://aws.amazon.com/cli/")
     (synopsis "Command line client for AWS")
     (description "AWS CLI provides a unified command line interface to the