summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-05-05 13:19:50 +0200
committerAndreas Enge <andreas@enge.fr>2013-06-14 20:58:18 +0200
commit7cf2a2a1e2e73ea413eb82bec513348473f19d96 (patch)
treebd1736bfce06aad59f8f299024ee643939184131
parent3e5980de4724eaeff19d914ad07f944faf4abd3c (diff)
downloadguix-7cf2a2a1e2e73ea413eb82bec513348473f19d96.tar.gz
gnu: Add libspectre.
* gnu/packages/ghostscript.scm (libspectre): New variable.
-rw-r--r--gnu/packages/ghostscript.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 04aac9d94e..dd6c576cdf 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -214,3 +214,23 @@ Ghostscript. It currently includes the 35 standard PostScript fonts.")
    (license license:gpl2)
    (home-page "http://sourceforge.net/projects/gs-fonts/")))
 
+(define-public libspectre
+  (package
+   (name "libspectre")
+   (version "0.2.7")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "http://libspectre.freedesktop.org/releases/libspectre-"
+                                version ".tar.gz"))
+            (sha256 (base32
+                     "1v63lqc6bhhxwkpa43qmz8phqs8ci4dhzizyy16d3vkb20m846z8"))))
+   (build-system gnu-build-system)
+   (inputs `(("ghostscript" ,ghostscript)
+             ("pkg-config" ,pkg-config)))
+   (synopsis "postscript rendering library")
+   (description
+    "libspectre is a small library for rendering Postscript documents.
+It provides a convenient easy to use API for handling and rendering
+Postscript documents.")
+   (license license:gpl2+)
+   (home-page "http://www.freedesktop.org/wiki/Software/libspectre")))