summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 15:05:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:56 +0000
commit7d920830274a2ed1bf236f7e95fe5d18dd1c1b9a (patch)
tree39eb623247465883b4f2079f4d8537c8125ed327
parent991e41553cdefe9192e4899b7323fbb34f56a269 (diff)
downloadguix-7d920830274a2ed1bf236f7e95fe5d18dd1c1b9a.tar.gz
gnu: python-aioftp: Update to 0.22.3.
* gnu/packages/python-web.scm (python-aioftp): Update to 0.22.3.
[build-system]: Swap to pyproject-build-system, there is no setup.py in
new release.
[arguments] <#:phases>: Use standard 'check phase.

Change-Id: I8e6a145da86e5ed56eb184d98d54bc8093a3bd1f
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index de57d5be94..cde4ac4f58 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3546,20 +3546,14 @@ adapter for use with the Requests library.")
 (define-public python-aioftp
   (package
     (name "python-aioftp")
-    (version "0.21.4")
+    (version "0.22.3")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "aioftp" version))
               (sha256
                (base32
-                "1f8vql2j2b3ykqyh5bxzsp8x5f2if2c1ya232ld3hz3cc7a2dfr8"))))
-    (build-system python-build-system)
-    (arguments
-     (list #:phases #~(modify-phases %standard-phases
-                        (replace 'check
-                          (lambda* (#:key tests? #:allow-other-keys)
-                            (when tests?
-                              (invoke "pytest" "-vvv")))))))
+                "0w621mg956m9rn7v39jpwi4gpnpl90pprwl29cp640dahqqv38ms"))))
+    (build-system pyproject-build-system)
     (native-inputs (list python-async-timeout python-pytest
                          python-pytest-asyncio python-pytest-cov
                          python-trustme))