summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-03-13 20:41:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-13 21:29:51 +0200
commit7df85799b11f5d3bebc6d7a0ba8d3b5b6df1c0f1 (patch)
treede90a6f4580e4b6b1cf3fb40e7373243f29c00a4
parent1bb4005fbd28806b8295f285c83deb197c2a32e9 (diff)
downloadguix-7df85799b11f5d3bebc6d7a0ba8d3b5b6df1c0f1.tar.gz
gnu: abcde: Use 'modify-phases'.
* gnu/packages/cdrom.scm (adcde)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/cdrom.scm59
1 files changed, 29 insertions, 30 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 16bec0487f..d39430de68 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -304,37 +304,36 @@ from an audio CD.")
                    (string-append "etcdir = $(prefix)/etc\n"))))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-replace
-                 'configure
-                 (lambda* (#:key outputs inputs #:allow-other-keys)
-                   (substitute* "Makefile"
-                     (("^prefix = .*$")
-                      (string-append "prefix = "
-                                     (assoc-ref outputs "out")
-                                     "\n"))))
-                 (alist-cons-after
-                  'install 'wrap
-                  (lambda* (#:key inputs outputs #:allow-other-keys)
-                    (let ((wget   (assoc-ref inputs "wget"))
-                          (vorbis (assoc-ref inputs "vorbis-tools"))
-                          (parano (assoc-ref inputs "cdparanoia"))
-                          (which  (assoc-ref inputs "which"))
-                          (discid (assoc-ref inputs "cd-discid"))
-                          (out    (assoc-ref outputs "out")))
-                      (define (wrap file)
-                        (wrap-program file
-                                      `("PATH" ":" prefix
-                                        (,(string-append out "/bin:"
-                                                         wget "/bin:"
-                                                         which "/bin:"
-                                                         vorbis "/bin:"
-                                                         discid "/bin:"
-                                                         parano "/bin")))))
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             (substitute* "Makefile"
+               (("^prefix = .*$")
+                (string-append "prefix = "
+                               (assoc-ref outputs "out")
+                               "\n")))))
+         (add-after 'install 'wrap
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((wget   (assoc-ref inputs "wget"))
+                   (vorbis (assoc-ref inputs "vorbis-tools"))
+                   (parano (assoc-ref inputs "cdparanoia"))
+                   (which  (assoc-ref inputs "which"))
+                   (discid (assoc-ref inputs "cd-discid"))
+                   (out    (assoc-ref outputs "out")))
+               (define (wrap file)
+                 (wrap-program file
+                               `("PATH" ":" prefix
+                                 (,(string-append out "/bin:"
+                                                  wget "/bin:"
+                                                  which "/bin:"
+                                                  vorbis "/bin:"
+                                                  discid "/bin:"
+                                                  parano "/bin")))))
 
-                      (for-each wrap
-                                (find-files (string-append out "/bin")
-                                            ".*"))))
-                  %standard-phases))
+               (for-each wrap
+                         (find-files (string-append out "/bin")
+                                     ".*"))))))
        #:tests? #f))
 
     (inputs `(("wget" ,wget)