summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2019-12-24 14:35:52 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-24 14:35:52 -0600
commit7e232d02ea574ba027b1c8a964d29b23b455fca7 (patch)
tree33c0175661cbaf804c10e240558d2cc52ef11707
parentd7c58c3e5449d9fb96a15928cc65f12f111d0569 (diff)
downloadguix-7e232d02ea574ba027b1c8a964d29b23b455fca7.tar.gz
gnu: qutebrowser: Add comment about tests.
* gnu/packages/web-browsers.scm (qutebrowser)[arguments]: Indicate that tests
  have been added, but to wait on fixing or working-around the failing test
  case for QtWebEngine until it is determined whether a liberated QtWebEngine
  can be made available or not.
-rw-r--r--gnu/packages/web-browsers.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 531c0e2f6d..7586011755 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -301,7 +301,12 @@ access.")
        ("python-pyqt" ,python-pyqt)
        ("qtwebkit" ,qtwebkit)))
     (arguments
-     `(#:tests? #f                      ;no tests
+     `(;; FIXME: Tests have been added to Qutebrowser. But they currently fail on
+       ;; trying to locate QtWebEngine, and run it on a specific display.
+       ;; There does not seem to be a trivial way to suppress this test.
+       ;; Either fix this, or wait for a liberated QtWebEngine to make into GNU Guix.
+       ;; Change this according to <https://bugs.gnu.org/35866>.
+       #:tests? #f
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-more
@@ -312,7 +317,6 @@ access.")
                (invoke "a2x" "-f" "manpage" "doc/qutebrowser.1.asciidoc")
                (install-file "doc/qutebrowser.1"
                              (string-append out "/share/man/man1"))
-
                (for-each
                 (lambda (i)
                   (let ((src  (format #f "icons/qutebrowser-~dx~d.png" i i))