summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-31 14:15:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-31 15:45:43 +0200
commit7e31427ff0ab85c6d7815da569b2f50ee10605ee (patch)
tree6a6b65d9a57899fdcc418e72f4029b2f5916dcc6
parent5883bb76f8117d0c7b5d83c537abbccccca7c80e (diff)
downloadguix-7e31427ff0ab85c6d7815da569b2f50ee10605ee.tar.gz
gnu: python-pyjwt: Update to 1.5.2 [fixes CVE-2017-11424].
* gnu/packages/python.scm (python-pyjwt): Update to 1.5.2.
[source]: Add snippet to remove pre-compiled files.
[native-inputs]: Change PYTHON-PYTEST to PYTHON-PYTEST-3.0.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 65c1c23b81..6d3a44a756 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2835,17 +2835,23 @@ somewhat intelligeble.")
 (define-public python-pyjwt
   (package
     (name "python-pyjwt")
-    (version "1.4.0")
+    (version "1.5.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "PyJWT" version))
        (sha256
         (base32
-         "1556v2jppd8mjkkj66pxb5rcazm35jq81r233mdl8hfmz9n3icp1"))))
+         "0pvr3iymab7v2qz74ann760z7qahqgqszxz5iqqbaqv4z2zz0y8i"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (for-each delete-file-recursively
+                     (find-files "." "\\.pyc$"))
+           #t))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-pytest" ,python-pytest)
+     `(("python-pytest" ,python-pytest-3.0)
        ("python-pytest-cov" ,python-pytest-cov)
        ("python-pytest-runner" ,python-pytest-runner)))
     (home-page "https://github.com/progrium/pyjwt")