summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:47:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:22 +0200
commit7e5d4d74623cdb2105629e5365292cf9cf06e362 (patch)
tree7d30ef3b05fc643af40e2e0756712cd3d6c58c3d
parent8e6935ebe210043451322ddd85d18cc855712517 (diff)
downloadguix-7e5d4d74623cdb2105629e5365292cf9cf06e362.tar.gz
gnu: Add texlive-simpler-wick.
* gnu/packages/tex.scm (texlive-simpler-wick): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 577b588be3..846950283f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6093,6 +6093,31 @@ The included @code{bnfgrammar} environment parses BNF expressions (possibly
 annotated), so users can write readable BNF expressions in their documents.")
     (license license:expat)))
 
+(define-public texlive-simpler-wick
+  (package
+    (name "texlive-simpler-wick")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/simpler-wick/"
+                   "tex/latex/simpler-wick/")
+             (base32
+              "0iicdx5n0ifjwifxk6i0242hkk388jz1mz01zpmznixjlhx780ni")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/simpler-wick")
+    (synopsis "Simpler Wick contractions")
+    (description
+     "In every quantum field theory course, there will be a chapter about
+Wick's theorem and how it can be used to convert a very large product of many
+creation and annihilation operators into something more tractable and normal
+ordered.  The contractions are denoted with a square bracket over the
+operators which are being contracted, which used to be rather annoying to
+typeset in LaTeX as the only other package available was simplewick, which is
+rather unwieldy.  This package provides a simpler syntax for Wick
+contractions.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")