summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-17 17:49:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:45 +0300
commit7eb2891cb8b96ea083dd942b30619a327d686ff1 (patch)
tree9292c06efa83d8ae30d8407e184bae08a7d69d50
parenta524a4b7d7960c1b34ce72c47a03f7e3c679837f (diff)
downloadguix-7eb2891cb8b96ea083dd942b30619a327d686ff1.tar.gz
gnu: Remove rust-aes-ctr-0.6.
* gnu/packages/crates-io.scm (rust-aes-ctr-0.6): Delete variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 66cd3cbb07..8254fddfa0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2020,32 +2020,6 @@ ciphers implementations.")
         ("rust-aesni" ,rust-aesni-0.6)
         ("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6))))))
 
-(define-public rust-aes-ctr-0.6
-  (package
-    (name "rust-aes-ctr")
-    (version "0.6.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "aes-ctr" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32 "0qspjxzrclnb83501595y01dhc0km1ssrbjnwlxhcrsdwp6w6abp"))))
-  (build-system cargo-build-system)
-  (arguments
-   `(#:cargo-inputs
-     (("rust-aes-soft" ,rust-aes-soft-0.6)
-      ("rust-aesni" ,rust-aesni-0.10)
-      ("rust-cipher" ,rust-cipher-0.2)
-      ("rust-ctr" ,rust-ctr-0.6))
-     #:cargo-development-inputs
-     (("rust-cipher" ,rust-cipher-0.2))))
-  (home-page "https://github.com/RustCrypto/block-ciphers/tree/master/aes")
-  (synopsis "Pure Rust implementation of AES")
-  (description "A pure Rust implementation of the Advanced Encryption Standard
-(AES).  Use the aes crate if possible, as the aes-ctr has been deprecated.")
-  (license (list license:expat license:asl2.0))))
-
 (define-public rust-aes-gcm-0.10
   (package
     (name "rust-aes-gcm")