summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-05-15 13:36:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 15:16:44 +0200
commit7ed113e1a53c9f39a4cbd3f4b7652582e84849e7 (patch)
tree5d8c7b9af09afe8615af1a7e2f5fedf21d73bc75
parentd66c44dd4f2a5083dbd044ef116d8fd95a217735 (diff)
downloadguix-7ed113e1a53c9f39a4cbd3f4b7652582e84849e7.tar.gz
gnu: rottlog: Fix aarch64 cross-compilation.
* gnu/packages/admin.scm (rottlog)[arguments]: Add a 'fix-configure phase to
replace outdated config.sub and config.guess, without aarch64 support,
[native-inputs]: add "automake".
-rw-r--r--gnu/packages/admin.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6083691e19..9822ba8a9b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1229,7 +1229,7 @@ at once based on a Perl regular expression.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags (list "ROTT_ETCDIR=/etc/rottlog" ;rc file location
+     `(#:configure-flags (list "ROTT_ETCDIR=/etc/rottlog" ;rc file location
                                "--localstatedir=/var")
 
        ;; Install example config files in OUT/etc.
@@ -1243,6 +1243,20 @@ at once based on a Perl regular expression.")
                       (substitute* "rc/rc"
                         (("/usr/sbin/sendmail") "sendmail"))
                       #t))
+                  (add-after 'unpack 'fix-configure
+                    (lambda* (#:key inputs native-inputs #:allow-other-keys)
+                      ;; Replace outdated config.sub and config.guess:
+                      (for-each (lambda (file)
+                                  (install-file
+                                   (string-append
+                                    (assoc-ref
+                                     (or native-inputs inputs) "automake")
+                                    "/share/automake-"
+                                    ,(version-major+minor
+                                      (package-version automake))
+                                    "/" file) "."))
+                                '("config.sub" "config.guess"))
+                      #t))
                   (add-after 'build 'set-packdir
                     (lambda _
                       ;; Set a default location for archived logs.
@@ -1263,6 +1277,7 @@ at once based on a Perl regular expression.")
                     (lambda _
                       (invoke "make" "install-info"))))))
     (native-inputs `(("texinfo" ,texinfo)
+                     ("automake" ,automake)
                      ("util-linux" ,util-linux))) ; for 'cal'
     (home-page "https://www.gnu.org/software/rottlog/")
     (synopsis "Log rotation and management")