summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-01-11 21:58:19 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-01-22 12:54:37 +0100
commit7fef5c1e2a2b287e763012eaeea3e0d3e7e50a56 (patch)
treec3d3194a4178e3f48cbe8d5b021b3833eaf49291
parent14d8c4fe6f76150f35606add7f4540e7127b072a (diff)
downloadguix-7fef5c1e2a2b287e763012eaeea3e0d3e7e50a56.tar.gz
gnu: devhelp: Update to 43.0.
* gnu/packages/gnome.scm (devhelp): Update to 43.0.
[arguments]: Update ‘skip-gtk-update-icon-cache’ accordingly.
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7a1b582282..491f2a2605 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6243,7 +6243,7 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
 (define-public devhelp
   (package
     (name "devhelp")
-    (version "41.3")
+    (version "43.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -6251,7 +6251,7 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1rxn6kciyfdhnjrcjyf02cn3rki2xgwb4wrg5plbzjvpqasq66ml"))))
+                "016xhpz16b9b13y7wnvkllymb4s2fb6ixvw190204bir0pyyxkk3"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -6260,8 +6260,9 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
          (add-after 'unpack 'skip-gtk-update-icon-cache
            ;; Don't create 'icon-theme.cache'.
            (lambda _
-             (substitute* "build-aux/meson/meson_post_install.py"
-               (("gtk-update-icon-cache") "true")))))))
+             (substitute* "meson.build"
+               (("gtk_update_icon_cache: true")
+                "gtk_update_icon_cache: false")))))))
     (propagated-inputs
      (list gsettings-desktop-schemas))
     (native-inputs