summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:44:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:29 +0200
commit80035f022205135902261c2988701bcd51146b0a (patch)
treef3ff63ee834a4e211f18892536e6e106936cf512
parent86c6ba99f6e300e6ea7a4bee466912cb2bbe2a2c (diff)
downloadguix-80035f022205135902261c2988701bcd51146b0a.tar.gz
gnu: Add texlive-newcomputermodern.
* gnu/packages/tex.scm (texlive-newcomputermodern): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 88171f8e1f..fc2257c228 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19494,6 +19494,28 @@ Harvard at Newcastle style recommended by Newcastle University.  It should be
 used alongside @code{natbib} for citations.")
     (license license:lppl1.3c)))
 
+(define-public texlive-newcomputermodern
+  (package
+    (name "texlive-newcomputermodern")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/newcomputermodern/"
+                   "fonts/opentype/public/newcomputermodern/"
+                   "tex/latex/newcomputermodern/")
+             (base32
+              "0b2iingsax99r551150w26zwmlr6a8yjwb00amfa2id390r1yjp5")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/newcomputermodern")
+    (synopsis "Computer Modern fonts including matching non-Latin alphabets")
+    (description
+     "This is a new assembly of Computer Modern fonts including extensions in
+many directions for both Latin based languages, non-Latin based languages and
+Mathematics, all compatible in style to CM fonts.  In addition to the Regular
+weight of Computer Modern, it provides a Book weight for heavier printing.")
+    (license license:gfl1.0)))
+
 (define-public texlive-nicematrix
   (package
     (name "texlive-nicematrix")