summary refs log tree commit diff
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-05-20 09:07:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-20 09:33:03 +0200
commit804b7722a5272dffe659368404a3447e509f2cea (patch)
tree5e70b65887d8e5e0eae5cf18185af5f6a97dd28e
parent79ddf25bc0a26a52ffe88c144d6ce2645462fa05 (diff)
downloadguix-804b7722a5272dffe659368404a3447e509f2cea.tar.gz
gnu: Add python-plaster-pastedeploy.
* gnu/packages/python-web.scm (python-plaster-pastedeploy): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index adc68f48c7..ddd94c09cb 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3923,3 +3923,27 @@ basic API that applications may use to find and load configuration settings.
 Any specific constraints should be implemented in a pluggable loader which can
 be registered via an entrypoint.")
     (license license:repoze)))
+
+(define-public python-plaster-pastedeploy
+  (package
+    (name "python-plaster-pastedeploy")
+    (version "0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "plaster_pastedeploy" version))
+              (sha256
+               (base32
+                "1zg7gcsvc1kzay1ry5p699rg2qavfsxqwl17mqxzr0gzw6j9679r"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-plaster" ,python-plaster)
+       ("python-pastedeploy" ,python-pastedeploy)))
+    (home-page "https://github.com/Pylons/plaster_pastedeploy")
+    (synopsis "Plugin for python-plaster adding PasteDeploy syntax")
+    (description
+     "This plugin for @code{python-plaster} adds support for PasteDeploy
+syntax, it provides a plaster @code{Loader} object that can parse ini files
+according to the standard set by PasteDeploy ")
+    (license license:expat)))