summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-18 01:17:17 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-02 21:53:44 +0100
commit8076a18e32cc82d72360535316aecbf80f8f459a (patch)
tree3f3ae8835ef009d6a2d59c8434aee14d26ad35c3
parent472a74bf6fa6d4d106251fdfcdf3800e439d2346 (diff)
downloadguix-8076a18e32cc82d72360535316aecbf80f8f459a.tar.gz
gnu: Add rust-hashbrown-0.9.
* gnu/packages/crates-io.scm (rust-hashbrown-0.9): New variable, skipping
  build.  (rust-hashbrown-0.8): Inherit from rust-hashbrown-0.9.
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 35 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index df6fe11282..3c4c52cdc6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11131,10 +11131,10 @@ the template engine that renders the official Rust website")
 @code{#[derive(Hash32)]}.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-hashbrown-0.8
+(define-public rust-hashbrown-0.9
   (package
     (name "rust-hashbrown")
-    (version "0.8.0")
+    (version "0.9.1")
     (source
      (origin
        (method url-fetch)
@@ -11142,11 +11142,12 @@ the template engine that renders the official Rust website")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "09y86zmf59n6ys9yf2bvg9ckwwa1ijv2i3flkz45iqkwfmh7i6xb"))))
+         "016dsm9s4xmxlkw2jfikm54qlz6vyk0qr280gab7kzp342jf9byp"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
-       (("rust-ahash" ,rust-ahash-0.3)
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-ahash" ,rust-ahash-0.4)
         ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
         ("rust-rayon" ,rust-rayon-1)
         ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
@@ -11165,6 +11166,35 @@ the template engine that renders the official Rust website")
 hash map.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-hashbrown-0.8
+  (package
+    (inherit rust-hashbrown-0.9)
+    (name "rust-hashbrown")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hashbrown" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "09y86zmf59n6ys9yf2bvg9ckwwa1ijv2i3flkz45iqkwfmh7i6xb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ahash" ,rust-ahash-0.3)
+        ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+        ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+        ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-doc-comment" ,rust-doc-comment-0.3)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-rand" ,rust-rand-0.7)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-rustc-hash" ,rust-rustc-hash-1.0)
+        ("rust-serde-test" ,rust-serde-test-1))))))
+
 (define-public rust-hashbrown-0.5
   (package
     (inherit rust-hashbrown-0.8)