summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-31 13:59:12 +0000
committerChristopher Baines <mail@cbaines.net>2017-12-31 14:11:46 +0000
commit809b884260b42c56c87c6c2263c5d9209aca86ce (patch)
tree57952fa28594bd3684604bd4ba46781191d7d2dc
parent091191c3dcbfb9f01070d26bf15cb2c4dd07b1b5 (diff)
downloadguix-809b884260b42c56c87c6c2263c5d9209aca86ce.tar.gz
gnu: packages: 0ad: Tweak the build options.
Use the -C make option, rather than changing directory before the build
phase. Add config=release to the make flags as this might improve performance,
and verbose=1 as this might make the build process clearer.

Also remove --minimal-flags, as I don't quite understand what this does, but
using it seems to remove lots of flags that would be used by default.

* gnu/packages/games.scm (0ad)[arguments]: Add #:make-flags, remove the
  --minimal-flags argument from the configure phase, remove the 'chdir phase,
  and change the chdir argument in the install phase.
-rw-r--r--gnu/packages/games.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0128d6372b..ce799ae33b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4922,7 +4922,8 @@ fight against their plot and save his fellow rabbits from slavery.")
        ("python-2" ,python-2)))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:make-flags '("config=release" "verbose=1" "-C" "build/workspaces/gcc")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'delete-bundles
            (lambda _
@@ -4949,17 +4950,12 @@ fight against their plot and save his fellow rabbits from slavery.")
                  (zero? (system* "./update-workspaces.sh"
                                  (string-append "--libdir=" lib)
                                  (string-append "--datadir=" data)
-                                 "--minimal-flags"
                                  ;; TODO: "--with-system-nvtt"
                                  "--with-system-mozjs38"))))))
-         (add-before 'build 'chdir
-           (lambda _
-             (chdir "build/workspaces/gcc")
-             #t))
          (delete 'check)
          (replace 'install
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (chdir "../../../binaries")
+             (chdir "binaries")
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
                     (lib (string-append out "/lib"))