summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-27 20:53:48 +0100
committerLudovic Courtès <ludo@gnu.org>2015-10-27 21:44:46 +0100
commit816a653884558feab29ccf470c972262708309f9 (patch)
treed4cc6410a0186db10b26ba395da8402cc2da4386
parent85d4aeacc49f2793b7d67914fd4086e2d7b2e6f8 (diff)
downloadguix-816a653884558feab29ccf470c972262708309f9.tar.gz
gnu: Add python-chardet.
* gnu/packages/python.scm (python-chardet, python2-chardet): New
  variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8fc87599fd..45fd417e86 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5817,3 +5817,30 @@ Debian-related files, such as:
 
 (define-public python2-debian
   (package-with-python2 python-debian))
+
+(define-public python-chardet
+  (package
+    (name "python-chardet")
+    (version "2.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/c/chardet/chardet-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1ak87ikcw34fivcgiz2xvi938dmclh078az65l9x3rmgljrkhgp5"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/chardet/chardet")
+    (synopsis "Universal encoding detector for Python 2 and 3")
+    (description
+     "This package provides @code{chardet}, a Python module that can
+automatically detect a wide range of file encodings.")
+    (license lgpl2.1+)))
+
+(define-public python2-chardet
+  (package-with-python2 python-chardet))