summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-24 21:44:44 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-24 21:48:07 -0400
commit8172ab2dde425cbd7fb6e633ceff634990acbefb (patch)
tree5f366070a9e000492a11ab05c58e29293c8f0f8c
parent91f55717abd05a5808eb6b3a0b397bee4e8edd09 (diff)
downloadguix-8172ab2dde425cbd7fb6e633ceff634990acbefb.tar.gz
gnu: starfighter: Update to 2.0.0.3.
* gnu/packages/games.scm (starfighter): Update to 2.0.0.3.
[source]: Use url-fetch and remove 'file-name' field.
[native-inputs]: Remove autoconf and automake.
-rw-r--r--gnu/packages/games.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 266a2d3bac..a17ac9728c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3264,26 +3264,19 @@ tactics.")
 (define-public starfighter
   (package
     (name "starfighter")
-    (version "2.0.0.2")
-    ;; As recommended by the upstream maintainer, use the git source code
-    ;; instead of the released source tarball until missing files in the tarball
-    ;; are added.  The 'url-fetch' method may be appropriate again after the
-    ;; next update.  See https://github.com/pr-starfighter/starfighter/issues/1
-    ;; for more details.
+    (version "2.0.0.3")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/pr-starfighter/starfighter")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/pr-starfighter/starfighter/releases"
+                    "/download/v" version "/starfighter-"
+                    (version-major+minor version) "-src.tar.gz"))
               (sha256
                (base32
-                "0p81ywgm2dxjbpmbsgx4f2d83sy6lv3hinrr1vzprkf9viidqnd2"))))
+                "13vi5kh9ahws4f52421cbyw0jn7pmbnld358lqfmr6flql7ilj3b"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("pango" ,pango)
        ("sdl2" ,sdl2)