summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-10 16:53:30 +0200
committerMarius Bakke <marius@gnu.org>2021-05-13 17:03:48 +0200
commit817507f0ab993f655779670483e5750e50b70e1e (patch)
treed58ba731f29b256195c989e39da3d795a93bb9cc
parent03b6cfa0c2e449e633681c69899bd1f14e99fb81 (diff)
downloadguix-817507f0ab993f655779670483e5750e50b70e1e.tar.gz
gnu: GTK+: Remove unused inputs.
* gnu/packages/gtk.scm (gtk+)[inputs]: Remove PAPI, which is not the Papi GTK+
expects.
[native-inputs]: Remove INTLTOOL, which is not used by current GNOME projects.
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ea5d8f329b..2ed28af03f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -88,7 +88,6 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pretty-print)
-  #:use-module (gnu packages profiling)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages guile)
@@ -979,17 +978,13 @@ application suites.")
        ("wayland" ,wayland)
        ("wayland-protocols" ,wayland-protocols)))
     (inputs
-     `(;; XXX: colord depends on mozjs (through polkit), which fails on
-       ;;      on non-intel systems now.
-       ("colord" ,colord)
+     `(("colord" ,colord)
        ("cups" ,cups)
        ("graphene" ,graphene)
        ("harfbuzz" ,harfbuzz)
        ("iso-codes" ,iso-codes)
        ("json-glib" ,json-glib)
        ("libxml2" ,libxml2)
-       ("papi" ,papi)
-       ;; XXX: rest depends on p11-kit, which fails on mips64el now.
        ("rest" ,rest)))
     (native-inputs
      `(("docbook-xml" ,docbook-xml-4.1.2)
@@ -997,7 +992,6 @@ application suites.")
        ("glib" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("hicolor-icon-theme" ,hicolor-icon-theme)
-       ("intltool" ,intltool)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)