summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:41 +0200
commit817fcca13da452fb2a848b13da196b1e96efea72 (patch)
tree575ecfd7c16cba0b516833050de72a4e66cbfcb2
parent32b463508aedf4d882c577d684b36024ae82223a (diff)
downloadguix-817fcca13da452fb2a848b13da196b1e96efea72.tar.gz
gnu: Add texlive-rjlparshap.
* gnu/packages/tex.scm (texlive-rjlparshap): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e1f0f72e0c..1314984033 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94049,6 +94049,28 @@ purpose of combining the preferences used in the author's own package
 documentations.")
     (license license:lppl1.2+)))
 
+(define-public texlive-rjlparshap
+  (package
+    (name "texlive-rjlparshap")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/rjlparshap/"
+                   "source/latex/rjlparshap/"
+                   "tex/latex/rjlparshap/")
+             (base32
+              "1csigz0i8a1zlrzlv0wl5dc5rqbpjkfhadaib5y92qb54n4aqi36")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/rjlparshap")
+    (synopsis "Support for use of @code{\\parshape} in LaTeX")
+    (description
+     "The package provides macros and environments that relieve the programmer of
+some of the difficulties of using @code{\\parshape} in LaTeX macros.  It does
+not actually calculate shapes in the way that the @code{shapepar} package
+does.")
+    (license license:lppl1.2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar