summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-03-18 12:48:16 +0800
committer宋文武 <iyzsong@gmail.com>2015-03-23 22:06:57 +0800
commit83bb3a3ee4292d75cc6cfe08947ffb12989eccba (patch)
tree4e715c8a437e3c99f66c1c419311c095b3566ed2
parentef5cbf9bae96555fc0c1983f30bd466476027b20 (diff)
downloadguix-83bb3a3ee4292d75cc6cfe08947ffb12989eccba.tar.gz
gnu: sdl: Allow dlopen for OpenGL.
Fixes a regression introduced in 666aa99.
Reported by Felipe López and David Thompson.

* gnu/packages/sdl.scm (sdl)[inputs]: Add glu.
  [arguments]<#:configure-flags>: Replace '--disable-sdl-dlopen' with
  '--disable-alsa-shared --disable-pulseaudio-shared --disable-x11-shared'.
-rw-r--r--gnu/packages/sdl.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 03aa56d118..fd555f9068 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -60,8 +60,11 @@
     (build-system gnu-build-system)
     (arguments
      '(;; Explicitly link against shared libraries instead of dlopening them.
-       ;; For X11, ALSA, PulseAudio, etc.
-       #:configure-flags '("--disable-sdl-dlopen")
+       ;; For X11, ALSA, and PulseAudio.
+       ;; OpenGL library is still dlopened at runtime.
+       #:configure-flags '("--disable-alsa-shared"
+                           "--disable-pulseaudio-shared"
+                           "--disable-x11-shared")
 
        #:tests? #f)) ; no check target
     (propagated-inputs
@@ -71,6 +74,7 @@
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("libxrandr" ,libxrandr)
               ("mesa" ,mesa)
+              ("glu" ,glu)
               ("alsa-lib" ,alsa-lib)
               ("pulseaudio" ,pulseaudio)))
     (synopsis "Cross platform game development library")