summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-28 10:02:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:00 +0200
commit845091073d7a05f8929bec8c11822d1844ff5a78 (patch)
tree8dff6f1b0f54502f5783b702d5afca7747b66a1a
parented41b6db71fb61f316abaa18164fea88a4943b5c (diff)
downloadguix-845091073d7a05f8929bec8c11822d1844ff5a78.tar.gz
gnu: Remove rust-src-1.64.
* gnu/packages/rust.scm (rust-src-1.64): Remove variable.

Change-Id: I88f7ebed18e478f3982cad3c8586cff64dada1bb
-rw-r--r--gnu/packages/rust.scm19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index aef59fe3c2..d72d6b2e51 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -54,7 +54,6 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages)
   #:use-module (guix build-system cargo)
-  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -1038,21 +1037,3 @@ safety and thread safety guarantees.")
       (native-inputs (cons* `("gdb" ,gdb/pinned)
                             `("procps" ,procps)
                             (package-native-inputs base-rust))))))
-
-(define-public rust-src-1.64
-  (hidden-package
-   (package
-     (inherit rust-1.64)
-     (name "rust-src")
-     (build-system copy-build-system)
-     (native-inputs '())
-     (inputs '())
-     (native-search-paths '())
-     (outputs '("out"))
-     (arguments
-      `(#:install-plan
-        '(("library" "lib/rustlib/src/rust/library")
-          ("src" "lib/rustlib/src/rust/src"))))
-     (synopsis "Source code for the Rust standard library")
-     (description "This package provide source code for the Rust standard
-library, only use by rust-analyzer, make rust-analyzer out of the box."))))