summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 11:02:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:11 +0200
commit84e64537c9e70c984399944d1e5ea036325ef42c (patch)
tree4a9753a9307475e3675da76fad370d376c8c9080
parent6c7638e616d5a8a32130c057c3d4882e27ac2984 (diff)
downloadguix-84e64537c9e70c984399944d1e5ea036325ef42c.tar.gz
gnu: Add rust-drm-ffi-0.6.
* gnu/packages/crates-graphics.scm (rust-drm-ffi-0.6): New variable.

Change-Id: I93f01d35f24253327b491cbe4967cda3ee4861d8
-rw-r--r--gnu/packages/crates-graphics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 3e1489fdae..575e4bb02d 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -878,6 +878,27 @@ and iOS.")
      "This package provides a library to perform image color model conversion.")
     (license license:expat-0)))
 
+(define-public rust-drm-ffi-0.6
+  (package
+    (name "rust-drm-ffi")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "drm-ffi" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0par8xcrpnz1h53yam4ai9jpqc9as337vclzsn4hw9xnqhciqzds"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-drm-sys" ,rust-drm-sys-0.5)
+                       ("rust-nix" ,rust-nix-0.27))))
+    (home-page "https://github.com/Smithay/drm-rs")
+    (synopsis "Safe, low-level bindings to the Direct Rendering Manager API")
+    (description
+     "Safe, low-level bindings to the Direct Rendering Manager API.")
+    (license license:expat)))
+
 (define-public rust-drm-fourcc-2
   (package
     (name "rust-drm-fourcc")