summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 10:36:03 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commit850cc1cc6b9e15518566aa9c1df8bbf4d92867a4 (patch)
tree6cdab2531b8f7b30ddd84b1dd02e1da75a6c856a
parent2d6a506624ba3654da523ff16281beb885c2cd26 (diff)
downloadguix-850cc1cc6b9e15518566aa9c1df8bbf4d92867a4.tar.gz
gnu: lxqt-runner: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-runner): Update to 1.1.0.
[arguments]: Remove phases.
-rw-r--r--gnu/packages/lxqt.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index d9bf4fc65d..3c8d4fc8b7 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -667,14 +667,14 @@ Qt with LXQt.")
 (define-public lxqt-runner
   (package
     (name "lxqt-runner")
-    (version "0.17.0")
+    (version "1.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "0n53jbvkmp4vgi21a720gsvi407m4ybqk8xrpnm5f48yjr88r9i4"))))
+        (base32 "1wfng8g28mq97ibrgpfbj353i15vdimmjp83pfqrmkddx0yvzcdv"))))
     (build-system cmake-build-system)
     (inputs
      (list kwindowsystem
@@ -688,23 +688,7 @@ Qt with LXQt.")
            qtx11extras))
     (native-inputs
      (list pkg-config qttools-5 lxqt-build-tools))
-    (arguments
-     '(#:tests? #f                      ; no tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-source
-           (lambda _
-             (substitute* '("autostart/CMakeLists.txt")
-               (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
-                "DESTINATION \"etc/xdg"))
-             #t))
-         (add-after 'unpack 'patch-translations-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "CMakeLists.txt"
-               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
-                (string-append (assoc-ref outputs "out")
-                               "/share/lxqt/translations")))
-             #t)))))
+    (arguments '(#:tests? #f))          ; no tests
     (home-page "https://lxqt-project.org")
     (synopsis "Tool used to launch programs quickly by typing their names")
     (description "lxqt-runner provides a GUI that comes up on the desktop and