summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-03-18 08:48:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-05-09 19:20:18 +0200
commit851199ef57a7317b5c7e039a4ee1b500f70232da (patch)
tree2c9ce17faf200b1452a55635892e96fb2136bb89
parenta759cbffafbf67b3a03c80b5bdbe3f3478affc50 (diff)
downloadguix-851199ef57a7317b5c7e039a4ee1b500f70232da.tar.gz
gnu: python-starlette: Update to 0.25.0.
* gnu/packages/python-web.scm (python-starlette): Update to 0.25.0.
[source]: Switch to git-fetch and git-reference.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-hatchling, python-httpx, python-pytest, and
python-typing-extensions-next.
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 15f51d91d9..e6310fad58 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8244,14 +8244,17 @@ SendGrid Web API v3 endpoints, including the new v3 /mail/send.")
 (define-public python-starlette
   (package
     (name "python-starlette")
-    (version "0.20.4")
+    (version "0.25.0")
     (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "starlette" version))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/encode/starlette")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "112hmwk4fh4dl21nlr2xd37h43xzxpjxfnic7v7fz3wr5w9g7z22"))))
-    (build-system python-build-system)
+                "1mkkj15lphgycnp51dnrfxbyrx3dicjdcpsqvwc7yw55zyih6h5k"))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-anyio
                              python-typing-extensions
                              ;; [all] extra dependencies:
@@ -8260,6 +8263,10 @@ SendGrid Web API v3 endpoints, including the new v3 /mail/send.")
                              python-multipart
                              python-pyyaml
                              python-requests))
+    (native-inputs (list python-hatchling
+                         python-httpx
+                         python-pytest
+                         python-typing-extensions))
     (home-page "https://github.com/encode/starlette")
     (synopsis "Little ASGI library")
     (description