summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-02-22 20:42:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-02-22 21:02:56 +0200
commit85280804056c1c3acc2da39bcc5f2647a8535939 (patch)
tree7d24f7bb750e60fb1b765d72bf4878da5e28ef9e
parente89bfc2dfd68def20e588d5216aea1bf7fa80e50 (diff)
downloadguix-85280804056c1c3acc2da39bcc5f2647a8535939.tar.gz
gnu: dolphin-emu: Shorten the source snippet.
* gnu/packages/emulators.scm (dolphin-emu): Rewrite the source snippet
to be more compact.
-rw-r--r--gnu/packages/emulators.scm40
1 files changed, 13 insertions, 27 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 530ef7da00..d55e68d74e 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -119,33 +119,19 @@
                (url "https://github.com/dolphin-emu/dolphin.git")
                (commit commit)))
          (file-name (git-file-name name version))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (for-each delete-file-recursively
-                            ;; Remove external stuff we don't need.
-                            '("Externals/LZO"
-                              "Externals/OpenAL"
-                              "Externals/Qt"
-                              "Externals/SFML"
-                              "Externals/SOIL"
-                              "Externals/curl"
-                              "Externals/ffmpeg"
-                              "Externals/gettext"
-                              "Externals/hidapi"
-                              "Externals/libpng"
-                              "Externals/libusb"
-                              "Externals/mbedtls"
-                              "Externals/miniupnpc"
-                              "Externals/wxWidgets3"
-                              "Externals/zlib"))
-                  ;; Clean up source.
-                  (for-each delete-file (find-files "." "\\.bin$"))
-                  (for-each delete-file (find-files "." "\\.dsy$"))
-                  (for-each delete-file (find-files "." "\\.exe$"))
-                  (for-each delete-file (find-files "." "\\.jar$"))
-                  (for-each delete-file (find-files "." "\\.rar$"))
-                  #t))
+         (modules '((guix build utils)))
+         (snippet
+          '(begin
+             ;; Remove external stuff we don't need.
+             (for-each (lambda (dir)
+                         (delete-file-recursively
+                           (string-append "Externals/" dir)))
+                       '("LZO" "OpenAL" "Qt" "SFML" "SOIL" "curl" "ffmpeg"
+                         "gettext" "hidapi" "libpng" "libusb" "mbedtls"
+                         "miniupnpc" "wxWidgets3" "zlib"))
+             ;; Clean up source.
+             (for-each delete-file (find-files "." ".*\\.(bin|dsy|exe|jar|rar)$"))
+             #t))
          (sha256
           (base32
            "0g725wmhlim73zrhi47wmr1bmplpy4b7sbimd5pm8xpfhj5nm10l"))))