summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-29 15:15:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-29 15:47:11 +0200
commit85eec227e1b056e808719b0db7756c4aa9745704 (patch)
tree3f699ec2d847fc24e0c9eaa27d9b11e7e41c7c39
parentee81abe23c4d17094df3b17e701d22aaccdc87e8 (diff)
downloadguix-85eec227e1b056e808719b0db7756c4aa9745704.tar.gz
gnu: vdirsyncer: Update to 0.16.8.
* gnu/packages/dav.scm (vdirsyncer): Update to 0.16.8.
[propagated-inputs]: Use python-click-5.
-rw-r--r--gnu/packages/dav.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 1b837dfe40..dbfa4a660e 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -60,13 +61,14 @@ clients.")
 (define-public vdirsyncer
   (package
     (name "vdirsyncer")
-    (version "0.16.7")
+    ;; When updating, check whether python-click-5 can be removed entirely.
+    (version "0.16.8")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri name version))
              (sha256
               (base32
-               "1vqjhn2bffy2bx45a1r14crsyn2cylf5by567g44c4mhpjwwz6vc"))))
+               "1i8kp9j99rs8xdhrc1vx749zd9wznlzj0pb3s05xdm71a8pl5nxz"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; The test suite is very flakey.
@@ -107,7 +109,8 @@ clients.")
        ("radicale" ,radicale)))
     (propagated-inputs
      `(("python-atomicwrites" ,python-atomicwrites)
-       ("python-click" ,python-click)
+       ;; XXX https://github.com/mitsuhiko/click/issues/200
+       ("python-click" ,python-click-5)
        ("python-click-log" ,python-click-log)
        ("python-click-threading" ,python-click-threading)
        ("python-requests-toolbelt" ,python-requests-toolbelt)))