summary refs log tree commit diff
diff options
context:
space:
mode:
authorEvgeny Pisemsky <evgeny@pisemsky.com>2023-04-22 15:00:00 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-23 17:06:11 +0200
commit86079683c2b8cc877df835147e701d3fc07c8a75 (patch)
tree2703bfa765715c62ef50f2d234856512a6bfe372
parentfd62a5d5c12f5b013081227578661dfa23b8e1d2 (diff)
downloadguix-86079683c2b8cc877df835147e701d3fc07c8a75.tar.gz
gnu: Add emacs-gemini.
* gnu/packages/emacs-xyz.scm (emacs-gemini): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b9bece1365..06bf8f18ee 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -126,6 +126,7 @@
 ;;; Copyright © 2020, 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;; Copyright © 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31367,6 +31368,28 @@ name (with autocompletion), a simple bookmark management system and
 connections using TLS encryption.")
     (license license:gpl3+)))
 
+(define-public emacs-gemini
+  (package
+    (name "emacs-gemini")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.carcosa.net/jmcbray/gemini.el")
+                    (commit "a7dd7c6ea4e036d0d5ecc4a5d284874c400f10ba")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pvlk56mhh4xh4gwzqldfk79jsjbcpivv5scd9811pv3afc30gsx"))))
+    (build-system emacs-build-system)
+    (home-page "https://git.carcosa.net/jmcbray/gemini.el")
+    (synopsis "Syntax highlighting for text/gemini")
+    (description
+     "This is a very simple syntax-highlighting mode for text/gemini documents.
+Currently, support is not complete, but it should be enough to help with basic
+documents.")
+    (license license:agpl3+)))
+
 (define-public emacs-zerodark-theme
   (package
     (name "emacs-zerodark-theme")