summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-02-15 15:42:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-15 16:04:29 +0100
commit867e2b1bb32cef651200cdd65042557f5c808909 (patch)
tree40c97b97ae7d049bb206b33fa10394678c92f8c4
parent9680047cda24a21e6823dfa49a3c7fbaf092a569 (diff)
downloadguix-867e2b1bb32cef651200cdd65042557f5c808909.tar.gz
gnu: Add r-rsvd.
* gnu/packages/cran.scm (r-rsvd): New variable.
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7e2539da81..82fd465d79 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10618,3 +10618,35 @@ the local machine to, say, distributed processing on a remote compute cluster.")
 can be resolved using any future-supported backend, e.g. parallel on the local
 machine or distributed on a compute cluster.")
     (license license:gpl2+)))
+
+(define-public r-rsvd
+  (package
+    (name "r-rsvd")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rsvd" version))
+       (sha256
+        (base32
+         "0vjhrvnkl9rmvl8sv2kac5sd10z3fgxymb676ynxzc2pmhydy3an"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)))
+    (home-page "https://github.com/erichson/rSVD")
+    (synopsis "Randomized singular value decomposition")
+    (description
+     "Low-rank matrix decompositions are fundamental tools and widely used for
+data analysis, dimension reduction, and data compression.  Classically, highly
+accurate deterministic matrix algorithms are used for this task.  However, the
+emergence of large-scale data has severely challenged our computational
+ability to analyze big data.  The concept of randomness has been demonstrated
+as an effective strategy to quickly produce approximate answers to familiar
+problems such as the @dfn{singular value decomposition} (SVD).  This package
+provides several randomized matrix algorithms such as the randomized singular
+value decomposition (@code{rsvd}), randomized principal component
+analysis (@code{rpca}), randomized robust principal component
+analysis (@code{rrpca}), randomized interpolative decomposition (@code{rid}),
+and the randomized CUR decomposition (@code{rcur}).  In addition several plot
+functions are provided.")
+    (license license:gpl3+)))