summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:57:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:57:27 +0300
commit86fd77476d550796c713d641b8d2397f2f31676e (patch)
tree8917fe4b3afb7066b12f4b3f0d29f6dc1cb15197
parentde0954d18c70c8959243696d4519c2ac58271ff6 (diff)
downloadguix-86fd77476d550796c713d641b8d2397f2f31676e.tar.gz
gnu: p7zip: Adjust custom configure phase.
* gnu/packages/compression.scm (p7zip)[arguments]: Use new target macros
to simplify custom 'configure phase.
-rw-r--r--gnu/packages/compression.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 561f134c4c..b68bb7a002 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1334,18 +1334,15 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key system outputs #:allow-other-keys)
-             (invoke "cp"
-                     (let ((system ,(or (%current-target-system)
-                                        (%current-system))))
-                       (cond
-                        ((string-prefix? "x86_64" system)
-                         "makefile.linux_amd64_asm")
-                        ((string-prefix? "i686" system)
-                         "makefile.linux_x86_asm_gcc_4.X")
-                        (else
-                         "makefile.linux_any_cpu_gcc_4.X")))
-                     "makefile.machine")))
+           (lambda _
+             (copy-file
+               ,(cond ((target-x86-64?)
+                       "makefile.linux_amd64_asm")
+                      ((target-x86-32?)
+                       "makefile.linux_x86_asm_gcc_4.X")
+                      (else
+                        "makefile.linux_any_cpu_gcc_4.X"))
+               "makefile.machine")))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?