summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-24 18:36:15 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-24 18:36:15 +0200
commit878c8f3f470030b51fb854a205a38df8417f1115 (patch)
tree6f658a117e8afd136e8cf75b159883764218b22b
parent47e0ba8fe54ad98f5d4e6bdc45b1ec5017e09c0b (diff)
downloadguix-878c8f3f470030b51fb854a205a38df8417f1115.tar.gz
gnu: mpfrcx: Propagate inputs.
* gnu/packages/algebra.scm (mpfrcx): Propagate inputs gmp, mpfr and mpc.
-rw-r--r--gnu/packages/algebra.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index c3445690bf..01303c33b8 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -46,9 +46,10 @@
              (base32
               "0grw66b255r574lvll1bqccm5myj2m8ajzsjaygcyq9zjnnbnhhy"))))
    (build-system gnu-build-system)
-   (inputs `(("gmp" ,gmp)
-             ("mpfr" ,mpfr)
-             ("mpc"  ,mpc)))
+   (propagated-inputs
+     `(("gmp" ,gmp)
+       ("mpfr" ,mpfr)
+       ("mpc"  ,mpc))) ; Header files are included by mpfrcx.h.
    (synopsis "Arithmetic of polynomials over arbitrary precision numbers")
    (description
     "Mpfrcx is a library for the arithmetic of univariate polynomials over