summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-23 09:28:23 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:30 +0300
commit87a221b68a359d73cd14de58b6ab2c031896c368 (patch)
tree9b232498093d4e70d112460151c0f15da0db7f78
parentd7e32a4ba207ab38aa4af0dfdfad2bb0db294795 (diff)
downloadguix-87a221b68a359d73cd14de58b6ab2c031896c368.tar.gz
gnu: Add rust-compact-str-0.7.
* gnu/packages/crates-io.scm (rust-compact-str-0.7): New variable.
-rw-r--r--gnu/packages/crates-io.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cfefec2757..34b00adb6a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12422,6 +12422,50 @@ idiomatic wrappers for Mac OS X's CommonCrypto library.")
      "Common path finds the common prefix between a set of paths.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-compact-str-0.7
+  (package
+    (name "rust-compact-str")
+    (version "0.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "compact_str" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1lbk5vkn6vriwx98pybfsgy093ga6ilpm5gkcd8v7cgcg5gq1w5z"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-arbitrary" ,rust-arbitrary-1)
+        ("rust-bytes" ,rust-bytes-1)
+        ("rust-castaway" ,rust-castaway-0.2)
+        ("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-itoa" ,rust-itoa-1)
+        ("rust-markup" ,rust-markup-0.13)
+        ("rust-proptest" ,rust-proptest-1)
+        ("rust-quickcheck" ,rust-quickcheck-1)
+        ("rust-rkyv" ,rust-rkyv-0.7)
+        ("rust-ryu" ,rust-ryu-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-smallvec" ,rust-smallvec-1)
+        ("rust-static-assertions" ,rust-static-assertions-1))
+       #:cargo-development-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-proptest" ,rust-proptest-1)
+        ("rust-quickcheck" ,rust-quickcheck-1)
+        ("rust-quickcheck-macros" ,rust-quickcheck-macros-1)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-test-case" ,rust-test-case-2)
+        ("rust-test-strategy" ,rust-test-strategy-0.2))))
+    (home-page "https://github.com/ParkMyCar/compact_str")
+    (synopsis "String type that stores strings on the stack, when possible")
+    (description
+     "This package provides a memory-efficient string type that transparently
+stores strings on the stack, when possible.")
+    (license license:expat)))
+
 (define-public rust-const-cstr-0.3
   (package
     (name "rust-const-cstr")