summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-31 00:24:26 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-31 01:15:38 +0100
commit882f034fa88361c703f382f08e158e15ce330c1d (patch)
tree140f1a25617f9153d842deed3b007c3613595d39
parenta7d46f12ac4f87ff3981a8f8ee14d700799d49ef (diff)
downloadguix-882f034fa88361c703f382f08e158e15ce330c1d.tar.gz
gnu: linux-libre: Build more virtio modules.
* gnu/packages/linux.scm (linux-libre): Append CONFIG_NET_9P_VIRTIO and
  CONFIG_VIRTIO_{NET,BLK,BALLOON} to '.config'.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8fe91b4e9f..553120ca2b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -168,6 +168,17 @@
                           _ before after)
                          (string-append "CONFIG_" before "VIRTIO"
                                         after "=m\n")))
+
+                      ;; XXX: For some reason, some virtio modules need to be
+                      ;; explicitly added.
+                      (let ((port (open-file ".config" "a")))
+                        (display (string-append "CONFIG_NET_9P_VIRTIO=m\n"
+                                                "CONFIG_VIRTIO_NET=m\n"
+                                                "CONFIG_VIRTIO_BLK=m\n"
+                                                "CONFIG_VIRTIO_BALLOON=m\n")
+                                 port)
+                        (close-port port))
+
                       (zero? (system* "make" "oldconfig")))
 
                     ;; Call the default `build' phase so `-j' is correctly