summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-09-30 20:20:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2015-10-01 19:39:34 +0300
commit88377435caf28768ce29bba1de5e664166a404dc (patch)
tree579738c7322faee6a7681d73ccf4593b04f15729
parent64cb2de5d08259f078586ce0fe4af29f4bd1e467 (diff)
downloadguix-88377435caf28768ce29bba1de5e664166a404dc.tar.gz
gnu: graphviz: Add "doc" output.
* gnu/packages/graphviz.scm (graphviz)[outputs, arguments]: New fields.
-rw-r--r--gnu/packages/graphviz.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index e1eb654643..09f475bd90 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,7 +60,16 @@
                    (substitute* "lib/gvc/Makefile"
                      (("am__append_5 *=.*")
                       "am_append_5 =\n")))
-                 %standard-phases)))
+                 (alist-cons-after
+                  'install 'move-docs
+                  (lambda* (#:key outputs #:allow-other-keys)
+                           (let ((out (assoc-ref outputs "out"))
+                                 (doc (assoc-ref outputs "doc")))
+                             (mkdir-p (string-append doc "/share/graphviz"))
+                             (rename-file (string-append out "/share/graphviz/doc")
+                                          (string-append doc "/share/graphviz/doc"))
+                             #t))
+                 %standard-phases))))
     (inputs
      `(("libXrender" ,libxrender)
        ("libX11" ,libx11)
@@ -76,6 +86,7 @@
     (native-inputs
      `(("bison" ,bison)
        ("pkg-config" ,pkg-config)))
+    (outputs '("out" "doc"))                      ; 5 MiB of html + pdfs
     (home-page "http://www.graphviz.org/")
     (synopsis "Graph visualization software")
     (description