summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-08 15:15:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-08 16:21:53 +0100
commit88fb156288a2f3d07a998ec8c19469de00399d56 (patch)
tree98ff327948d72949d2e3257e52688ac77d55499f
parentc8b38f8ea6a851872e0adea0d921bb0908aa48aa (diff)
downloadguix-88fb156288a2f3d07a998ec8c19469de00399d56.tar.gz
gnu: pcb: Update to 4.0.2.
* gnu/packages/engineering.scm (pcb): Update to 4.0.2.
[arguments]: Add build phase "fix-check-for-display".
-rw-r--r--gnu/packages/engineering.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 911f519e2f..32b2f2c806 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -185,14 +185,14 @@ utilities.")
 (define-public pcb
   (package
     (name "pcb")
-    (version "4.0.0")
+    (version "4.0.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pcb/pcb/pcb-" version
                                   "/pcb-" version ".tar.gz"))
               (sha256
                (base32
-                "1i6sk8g8h9avms142wl07yv20m1cm4c3fq3v6hybrhdxs2n17plf"))))
+                "1a7rilp75faidny0r4fdwdxkflyrqp6svxv9lbg7h868293962iz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -202,6 +202,14 @@ utilities.")
              (substitute* "configure"
                (("wish85") "wish8.6"))
              #t))
+         ;; It checks for "xhost", which we don't have.  This shouldn't
+         ;; matter, because the test is supposed to be skipped, but it causes
+         ;; "run_tests.sh" (and thus the "check" phase) to fail.
+         (add-after 'unpack 'fix-check-for-display
+           (lambda _
+             (substitute* "tests/run_tests.sh"
+               (("have_display=no") "have_display=yes"))
+             #t))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails.  Pending a