summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-05-19 16:46:34 +0200
committerRoel Janssen <roel@gnu.org>2018-05-19 23:22:24 +0200
commit89f8c2ac38045801564742030b6c000b23f6a6f0 (patch)
treecb87fea2d01d9bfee336ce4dfd56c6976f5fc5f3
parent593fe736674fadedd961c499e5758fa9c96a57aa (diff)
downloadguix-89f8c2ac38045801564742030b6c000b23f6a6f0.tar.gz
gnu: Add guile-sparql.
* gnu/packages/guile.scm (guile-sparql): New variable.
-rw-r--r--gnu/packages/guile.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 84f46d1cc4..8c704bebcc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -2336,4 +2336,28 @@ allows users to interact with the Guile REPL through Jupyter.")
       (home-page "https://github.com/jerry40/guile-kernel")
       (license license:gpl3+))))
 
+(define-public guile-sparql
+  (package
+   (name "guile-sparql")
+   (version "0.0.7")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append
+                  "https://github.com/roelj/guile-sparql/releases/download/"
+                  version "/guile-sparql-" version ".tar.gz"))
+            (sha256
+             (base32 "1drnvhsgl0gc5crmb16yyw1j98nkhwwcgssv9vgm36ng43nnzffd"))))
+   (build-system gnu-build-system)
+   (arguments `(#:tests? #f)) ; There are no tests.
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (inputs
+    `(("guile" ,guile-2.2)))
+   (home-page "https://github.com/roelj/guile-sparql")
+   (synopsis "SPARQL module for Guile")
+   (description "This package provides the functionality to query a SPARQL
+endpoint.  Additionally, it provides an interface to write SPARQL queries
+using S-expressions.")
+   (license license:gpl3+)))
+
 ;;; guile.scm ends here