summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:50 +0200
commit8a29fb69916ad579df47dbb7d9f444e663b07bb4 (patch)
tree3cbdc5473f8359b18d08bca274afd858e86ed107
parent728ca78c2359f8d593f99f75c143027b3ad371ab (diff)
downloadguix-8a29fb69916ad579df47dbb7d9f444e663b07bb4.tar.gz
gnu: Add texlive-savetrees.
* gnu/packages/tex.scm (texlive-savetrees): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3312a01681..86eb167252 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94541,6 +94541,33 @@ to give the glyph a unique name.  To do that, we define
 @code{\\XXX}.")
     (license license:lppl)))
 
+(define-public texlive-savetrees
+  (package
+    (name "texlive-savetrees")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/savetrees/"
+                   "doc/latex/savetrees/"
+                   "source/latex/savetrees/"
+                   "tex/latex/savetrees/")
+             (base32
+              "06vhi0yzdrry5l8xg1j3hm0c22af4hasdaivgrbgqbjxldll2dxa")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/savetrees")
+    (synopsis "Optimise the use of each page of a LaTeX document")
+    (description
+     "The goal of the @code{savetrees} package is to pack as much text as possible
+onto each page of a LaTeX document.  Admittedly, this makes the document far
+less attractive.  Nevertheless, @code{savetrees} is a simple way to save paper
+when printing draft copies of a document.  It can also be useful when trying
+to meet a tight page-length requirement for a conference or journal
+submission.  Most of the package options cover specific modifications to
+typesetting rules, but there are also options subtle, moderate and extreme
+options for the broad brush approach.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar