summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-02 23:39:30 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-02 23:39:30 +0100
commit8a7bbc35474780b008fe7b42194c9590dd0d8d5d (patch)
tree421d0b005abe4828d3d7a5164a4e0fb672627573
parentdfed0eca93b355fb04e7183a950362dc2ee3a846 (diff)
downloadguix-8a7bbc35474780b008fe7b42194c9590dd0d8d5d.tar.gz
gnu: wireshark: Update to 3.4.0.
* gnu/packages/networking.scm (wireshark): Update to 3.4.0.
[arguments]: Skip another failing test.
-rw-r--r--gnu/packages/networking.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 734f5611ca..cf1909ff28 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1287,24 +1287,27 @@ of the same name.")
 (define-public wireshark
   (package
     (name "wireshark")
-    (version "3.2.7")
+    (version "3.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.wireshark.org/download/src/wireshark-"
                            version ".tar.xz"))
        (sha256
-        (base32 "1nkhglzxj05hwhgzrgan4glv0z67rmasf9djx1dmqicwdnw2z0xy"))))
+        (base32 "1bm8jj2rviis9j9l6nixvhxcfx362y9iphkxssgmiz2kj6yypr37"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'remove-failing-test
-           ;; Test 31/32 fails with errors like "Program reassemble_test is
-           ;; not available".  Skipping it for now.
+           ;; Skip test suite failing with "Program reassemble_test is not
+           ;; available" and alike errors.  Also skip test suite failing with
+           ;; "AssertionError: Program extcap/sdjournal is not available"
+           ;; error.'
            (lambda _
              (substitute* "CMakeLists.txt"
-               (("suite_unittests" all) (string-append "# " all)))
+               (("suite_unittests" all) (string-append "# " all))
+               (("suite_extcaps" all) (string-append "# " all)))
              #t)))
        ;; Build process chokes during `validate-runpath' phase.
        ;;