summary refs log tree commit diff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-12 22:51:53 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-15 11:35:28 +0100
commit8acedeb3a97e00eaaba6c1b58eae931d039c76a6 (patch)
tree22414ed4ae6927ed192d1c71b8ee37023b335454
parent70d16d283571b8976b3329a239a19e59d64d18f2 (diff)
downloadguix-8acedeb3a97e00eaaba6c1b58eae931d039c76a6.tar.gz
gnu: Add go-github-com-tekwizely-go-parsing.
* gnu/packages/golang.scm (go-github-com-tekwizely-go-parsing): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d34bb1acb7..1d3fa59ce9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6644,6 +6644,31 @@ modifying them.")
 @end itemize")
     (license license:expat)))
 
+(define-public go-github-com-tekwizely-go-parsing
+  (let ((commit "1548cfb17df54d365ce9febed0677c06a40a8ceb")
+        (revision "0"))
+    (package
+      (name "go-github-com-tekwizely-go-parsing")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tekwizely/go-parsing")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0bv5amka8hb9crc7qvlzi2kbycqrnh9d46b9wgcs8wqzl0z7w609"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/tekwizely/go-parsing"))
+      (home-page "https://github.com/tekwizely/go-parsing")
+      (synopsis "Text parsing, with lexers, parsers, and related tools")
+      (description
+       "This package provides Go modules focused on text parsing, with lexers,
+parsers, and related tools.")
+      (license license:expat))))
+
 (define-public go-github.com-ulikunitz-xz
   (package
     (name "go-github.com-ulikunitz-xz")