summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-29 23:13:19 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-31 09:50:33 +0100
commit8ae5fb1321fb48281ddf8e3848327eff2a0cf622 (patch)
tree6278274688309ad0c8460153cbe5a51cbaf9b94e
parent9cef662c896c13b952c9b4bba8dcefd5750e71a0 (diff)
downloadguix-8ae5fb1321fb48281ddf8e3848327eff2a0cf622.tar.gz
gnu: Add rust-wayland-egl-0.28.
* gnu/packages/crates-graphics.scm (rust-wayland-egl-0.28): New variable.
-rw-r--r--gnu/packages/crates-graphics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index d88e412b6d..a600332679 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2033,6 +2033,32 @@ the wayland protocol, client side.")
        (("rust-nix" ,rust-nix-0.14)
         ("rust-wayland-sys" ,rust-wayland-sys-0.21))))))
 
+(define-public rust-wayland-egl-0.28
+  (package
+    (name "rust-wayland-egl")
+    (version "0.28.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wayland-egl" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1xd7iap0x4sidmy9dv02cdnxjhnbk9li7r7f39x9cg0i8xs50ly6"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-wayland-client" ,rust-wayland-client-0.28)
+        ("rust-wayland-sys" ,rust-wayland-sys-0.28))))
+    (home-page "https://github.com/smithay/wayland-rs")
+    (synopsis "Bindings to libwayland-egl")
+    (description
+     "This crate provides bindings for OpenGL/Vulkan support for
+Wayland client apps.  It allows to create an EGLSurface from any
+WlSurface, which can then play the role of the base surface for
+initializing an OpenGL or Vulkan context.")
+    (license license:expat)))
+
 (define-public rust-wayland-protocols-0.23
   (package
     (name "rust-wayland-protocols")