summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 13:54:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:14 +0200
commit8af92c8ffdcc2de5a4d0cca83543062f07d712b8 (patch)
tree7601188066a9731b52c5b81295bff11e360d9e24
parent81b55b1e77f66b7e47a6d08c8b54a3a31e0dc972 (diff)
downloadguix-8af92c8ffdcc2de5a4d0cca83543062f07d712b8.tar.gz
gnu: Add java-osgi-service-event.
* gnu/packages/java.scm (java-osgi-service-event): New variable.
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 18c87acd5f..d9a6b004f5 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2343,6 +2343,34 @@ and service platform for the Java programming language.  This package contains
 the OSGi Core module.")
     (license license:asl2.0)))
 
+(define-public java-osgi-service-event
+  (package
+    (name "java-osgi-service-event")
+    (version "1.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/osgi/org.osgi.service.event/"
+                                  version "/org.osgi.service.event-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "1nyhlgagwym75bycnjczwbnpymv2iw84zbhvvzk84g9q736i6qxm"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:jar-name "osgi-service-event.jar"))
+    (inputs
+     `(("java-osgi-annotation" ,java-osgi-annotation)
+       ("java-osgi-core" ,java-osgi-core)))
+    (home-page "http://www.osgi.org")
+    (synopsis "OSGi service event module")
+    (description
+     "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language.  This package contains
+the OSGi @code{org.osgi.service.event} module.")
+    (license license:asl2.0)))
+
 (define-public java-eclipse-osgi
   (package
     (name "java-eclipse-osgi")