summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:41:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:24 +0200
commit8afbebc8a293d72f7d47b53a8dfe0929673cd70d (patch)
tree60a3ace90b59a64effcd11c4419c980354e6b5fd
parent1dcfd89b8fd15d060c84ded0a6d0c7d117b67346 (diff)
downloadguix-8afbebc8a293d72f7d47b53a8dfe0929673cd70d.tar.gz
gnu: Add texlive-marcellus.
* gnu/packages/tex.scm (texlive-marcellus): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9d4eebd710..8a1d77b913 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17825,6 +17825,34 @@ Riichi (aka Japanese) Mahjong but can be used to typeset any style of
 mahjong.")
     (license (list license:expat license:cc-by4.0))))
 
+(define-public texlive-marcellus
+  (package
+    (name "texlive-marcellus")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/marcellus/"
+                   "fonts/enc/dvips/marcellus/"
+                   "fonts/map/dvips/marcellus/"
+                   "fonts/tfm/public/marcellus/"
+                   "fonts/truetype/public/marcellus/"
+                   "fonts/type1/public/marcellus/"
+                   "fonts/vf/public/marcellus/"
+                   "tex/latex/marcellus/")
+             (base32
+              "1nnc0v15sjwzivy504lvrrfyzjhha7p42nwp0qqy7pwspb7cqsm5")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/marcellus")
+    (synopsis "Marcellus fonts with LaTeX support")
+    (description
+     "This package provides LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX support for
+the Marcellus family of fonts, designed by Brian J. Bonislawsky.  Marcellus is
+a flared-serif family, inspired by classic Roman inscription letterforms.
+There is currently just a regular weight and small-caps.  The regular weight
+will be silently substituted for bold.")
+    (license (list license:silofl1.1 license:lppl))))
+
 (define-public texlive-margbib
   (package
     (name "texlive-margbib")