summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:26:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:18 +0200
commit8c442d08bf3332806741e69a72341bd90f04b4d9 (patch)
treecfbd745ed3adb45b8268ca6136853b42630b4673
parent5317c1c44ca84c3d190b1b0120ab73a73782ac7d (diff)
downloadguix-8c442d08bf3332806741e69a72341bd90f04b4d9.tar.gz
gnu: Add texlive-tex-font-errors-cheatsheet.
* gnu/packages/tex.scm (texlive-tex-font-errors-cheatsheet): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 424128f136..bc0c68b365 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25433,6 +25433,25 @@ an hierarchical file system, in a way that is well-defined, and is readily
 implementable.")
     (license license:fdl1.1+)))
 
+(define-public texlive-tex-font-errors-cheatsheet
+  (package
+    (name "texlive-tex-font-errors-cheatsheet")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tex-font-errors-cheatsheet/")
+             (base32
+              "0pfd5qphmizhxb2p4gg6809xcx1rlfkwqa6vs4f74457chcwljwn")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tex-font-errors-cheatsheet")
+    (synopsis "Cheat sheet outlining the most common TeX font errors")
+    (description
+     "This is a compact three-pages document highlighting the TeX flow of
+integrating fonts, and explains how some of the most common font-related error
+messages occur.  Also, hints are given on how to address those.")
+    (license license:lppl)))
+
 (define-public texlive-threeparttable
   (package
     (name "texlive-threeparttable")