summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-12 18:21:54 -0700
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:31 +0200
commit8c8f07785f187a7092ca043b385d3e6415209e6a (patch)
tree8be5968fe1ae3e6eff2339ff41bce5bd08111ac4
parent02fb3328f7a596693241f964c6ed452a0b6bf233 (diff)
downloadguix-8c8f07785f187a7092ca043b385d3e6415209e6a.tar.gz
gnu: inetutils: Convert to gexp.
* gnu/packages/admin.scm (inetutils): Convert to gexp; fix indentation.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: Ic61fa69040b4e554ad8303192167f331bec4e863
-rw-r--r--gnu/packages/admin.scm54
1 files changed, 28 insertions, 26 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b6c2be1f2f..813c3cd0a3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -973,32 +973,34 @@ re-executing them as necessary.")
                 "0q1257ci22g2jbdiqs00mharc1lqkbibdlkhj23f3si6qjxkn17s"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--localstatedir=/var"
-
-                           ;; Make sure 'PATH_PROCNET_DEV' gets defined when
-                           ;; cross-compiling (by default it does not.)
-                           ,@(if (%current-target-system)
-                                 '("--with-path-procnet-dev=/proc/net/dev")
-                                 '())
-                           ,@(if (target-hurd?)
-                                 '("--disable-rcp"
-                                   "--disable-rexec"
-                                   "--disable-rexecd"
-                                   "--disable-rlogin"
-                                   "--disable-rlogind"
-                                   "--disable-rsh"
-                                   "--disable-rshd"
-                                   "--disable-uucpd"
-                                   "--disable-whois")
-                                 '()))
-       ;; Make sure that canonical "coreutils" package is not referred.
-       #:make-flags
-       (list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
-                            (search-input-file %build-inputs "bin/cp")
-                            "\\\""))
-       ;; On some systems, 'libls.sh' may fail with an error such as:
-       ;; "Failed to tell switch -a apart from -A".
-       #:parallel-tests? #f))
+     (list
+      #:configure-flags
+      #~(list "--localstatedir=/var"
+
+              ;; Make sure 'PATH_PROCNET_DEV' gets defined when
+              ;; cross-compiling (by default it does not.)
+              #$@(if (%current-target-system)
+                     '("--with-path-procnet-dev=/proc/net/dev")
+                     '())
+              #$@(if (target-hurd?)
+                     '("--disable-rcp"
+                       "--disable-rexec"
+                       "--disable-rexecd"
+                       "--disable-rlogin"
+                       "--disable-rlogind"
+                       "--disable-rsh"
+                       "--disable-rshd"
+                       "--disable-uucpd"
+                       "--disable-whois")
+                     '()))
+      ;; Make sure that canonical "coreutils" package is not referred.
+      #:make-flags
+      #~(list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
+                             (search-input-file %build-inputs "bin/cp")
+                             "\\\""))
+      ;; On some systems, 'libls.sh' may fail with an error such as:
+      ;; "Failed to tell switch -a apart from -A".
+      #:parallel-tests? #f))
     (inputs
      (list coreutils
            shadow                     ;for login (used in telnetd and rlogind)