summary refs log tree commit diff
diff options
context:
space:
mode:
authorJan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>2020-05-02 11:31:13 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-02 12:04:58 +0200
commit8c98eb28084858d89bdf6a3bd90eb056bf31c49e (patch)
tree26f5ff32421eed0dfa413179692625dbb65f06b1
parentf06eefa31d9994c92cb6cb4bb956d645d00e6bfa (diff)
downloadguix-8c98eb28084858d89bdf6a3bd90eb056bf31c49e.tar.gz
gnu: jami: Add epoll support.
* gnu/packages/jami.scm (jami)[arguments]: Add epoll support on Linux systems.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/jami.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 67146dcd70..dda787b3cd 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -33,6 +33,7 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages multiprecision)
@@ -111,6 +112,11 @@
        (list "--disable-oss"
              "--disable-sound"
              "--disable-video"
+             ;; The following flag is Linux specific.
+             ,@(if (hurd-triplet? (or (%current-system)
+                                      (%current-target-system)))
+                   '()
+                   '("--enable-epoll"))
              "--enable-ext-sound"
              "--disable-speex-aec"
              "--disable-g711-codec"