summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 20:34:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 20:34:49 +0100
commit8ca2756e56fb625a5d90d73f0bcb87349ce54e80 (patch)
tree95d315d02c5cb2988d90c39b64b63d6fb9d81793
parent60e120da2293980b86b395d9f590c05381b09bd0 (diff)
downloadguix-8ca2756e56fb625a5d90d73f0bcb87349ce54e80.tar.gz
gnu: go-github-com-mitchellh-colorstring: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mitchellh-colorstring): Move
from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I298ae2f0e94847ff865375120e4953d290bbe883
-rw-r--r--gnu/packages/golang-xyz.scm23
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ab2b74bc2c..cd945fe006 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2507,6 +2507,29 @@ Domain Name Service}.  The API follows the less-is-more principle, by
 presenting a small interface.")
     (license license:bsd-3)))
 
+(define-public go-github-com-mitchellh-colorstring
+  (package
+    (name "go-github-com-mitchellh-colorstring")
+    (version "0.0.0-20190213212951-d06e56a500db")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mitchellh/colorstring")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/mitchellh/colorstring"))
+    (home-page "https://github.com/mitchellh/colorstring")
+    (synopsis "Functions to colorize strings for terminal output")
+    (description
+     "Colorstring provides functions for colorizing strings for terminal output.")
+    (license license:expat)))
+
 (define-public go-github-com-modern-go-concurrent
   (package
     (name "go-github-com-modern-go-concurrent")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ceaae9ebb7..4e3fe5bd10 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9122,28 +9122,6 @@ kubernetes-sigs/yaml is a permanent fork of
 @url{https://github.com/ghodss/yaml,ghodss/yaml}.")
     (license (list license:expat license:bsd-3))))
 
-(define-public go-github-com-mitchellh-colorstring
-  (package
-    (name "go-github-com-mitchellh-colorstring")
-    (version "0.0.0-20190213212951-d06e56a500db")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/mitchellh/colorstring")
-                    (commit (go-version->git-ref version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/mitchellh/colorstring"))
-    (home-page "https://github.com/mitchellh/colorstring")
-    (synopsis "Functions to colorize strings for terminal output")
-    (description
-     "Colorstring provides functions for colorizing strings for terminal output.")
-    (license license:expat)))
-
 (define-public go-github-com-google-go-jsonnet
   (package
     (name "go-github-com-google-go-jsonnet")