summary refs log tree commit diff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-20 21:28:01 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-22 11:34:07 +0300
commit8ca7ccbf0dad63d75637ffdc6a5105eb9a4a4673 (patch)
treebbd2b3a493790baf7d08788716fc2d200eb684c6
parent7a222107e769bfdbbd8fd557f7b5f7dd3811b0b0 (diff)
downloadguix-8ca7ccbf0dad63d75637ffdc6a5105eb9a4a4673.tar.gz
gnu: Add rust-librespot-metadata-0.4.
* gnu/packages/crates-io.scm (rust-librespot-metadata-0.4): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4b78d1fa7d..96e6ec9582 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37059,6 +37059,32 @@ channel and session.")
 Spotify.  This package contains the discovery logic.")
     (license license:expat)))
 
+(define-public rust-librespot-metadata-0.4
+  (package
+    (name "rust-librespot-metadata")
+    (version "0.4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "librespot-metadata" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "07626b84cghd3jabdvyqhn1v0lax9p1hhz6ldw2r4l6brcgkd03b"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:cargo-inputs
+           `(("rust-async-trait" ,rust-async-trait-0.1)
+             ("rust-byteorder" ,rust-byteorder-1)
+             ("rust-librespot-core" ,rust-librespot-core-0.4)
+             ("rust-librespot-protocol" ,rust-librespot-protocol-0.4)
+             ("rust-log" ,rust-log-0.4)
+             ("rust-protobuf" ,rust-protobuf-2))))
+    (home-page "https://github.com/librespot-org/librespot")
+    (synopsis "The metadata elements of Librespot")
+    (description "Part of Librespot, an open source client library for
+Spotify.  This package contains the metadata logic.")
+    (license license:expat)))
+
 (define-public rust-librespot-protocol-0.4
   (package
     (name "rust-librespot-protocol")